#2 Deprecated package analysis library

Open
opened 7 months ago by Nuggy · 0 comments
Nuggy commented 7 months ago
Collaborator

Old stuff that's used with no apperent replacement.

prompt-lite@0.1.1 is very old and should be checked, and possibly replaced. (dependency of 3 files)
(https://www.npmjs.com/package/prompt-lite)

skyn3t-gekko/plugins.js
skyn3t-gekko/core/prepareDateRange.js
skyn3t-gekko/plugins/mailer.js

Just needs updates, I think

node-pre-gyp@0.13.0 is old and should be replaced by @mapbox/node-pre-gyp

node-pre-gyp@0.11.0 is old and should be replaced by @mapbox/node-pre-gyp

pg-promise@8.7.5 is old and should be updated and verified to work...

axios@0.18.1 has a critical security vulnerability that is fixed in v0.21.1 it should be updated... and verified to work.

samsam@1.3.0: is old and should be replaced with @sinonjs/samsam and checked

babel-preset-es2015@6.24.1: 🙌 Thanks for using Babel: we recommend using babel-preset-env now: please read https://babeljs.io/env to update!

babel-eslint@7.2.3: should be updated in favor @babel/eslint-parser. This package will no longer receive updates.

chokidar@1.7.0: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.

core-js@2.6.12: needs to be updated in favor of core-js@3 and tested.

fsevents@1.2.13: shoule be updated to fsevents 2.

Needs update, but may create breaks

resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
Needs some reworking read this (https://github.com/lydell/resolve-url)
seems omitted

urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
Needs some reworking read this. (https://github.com/lydell/urix)
seems omitted

Dangling stuff, that seems unused.

mimelib@0.2.14 is old, and dosen't seem to be used with the code base. Probably should just remove this...

har-validator@5.1.5 is old and deperacated, but as far as I can tell is just dangling, can probably just remove without consiquance.

mkdirp@0.5.1 is old and it's advised to update to mkdirp 1.x. but may take some reworking, because it's not using promises.. I cannot find any instances of this in the code base, so it may be safe to omit.

# Old stuff that's used with no apperent replacement. **prompt-lite**@0.1.1 is very old and should be checked, and possibly replaced. (dependency of 3 files) (https://www.npmjs.com/package/prompt-lite) ``` skyn3t-gekko/plugins.js skyn3t-gekko/core/prepareDateRange.js skyn3t-gekko/plugins/mailer.js ``` # Just needs updates, I think **node-pre-gyp**@0.13.0 is old and should be replaced by @mapbox/node-pre-gyp **node-pre-gyp**@0.11.0 is old and should be replaced by @mapbox/node-pre-gyp **pg-promise**@8.7.5 is old and should be updated and verified to work... **axios**@0.18.1 has a critical security vulnerability that is fixed in v0.21.1 it should be updated... and verified to work. **samsam**@1.3.0: is old and should be replaced with @sinonjs/samsam and checked **babel-preset-es2015**@6.24.1: 🙌 Thanks for using Babel: we recommend using babel-preset-env now: please read https://babeljs.io/env to update! **babel-eslint**@7.2.3: should be updated in favor @babel/eslint-parser. This package will no longer receive updates. **chokidar**@1.7.0: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. **core-js**@2.6.12: needs to be updated in favor of core-js@3 and tested. **fsevents**@1.2.13: shoule be updated to fsevents 2. # Needs update, but may create breaks **resolve-url**@0.2.1: https://github.com/lydell/resolve-url#deprecated Needs some reworking read this (https://github.com/lydell/resolve-url) seems omitted **urix**@0.1.0: Please see https://github.com/lydell/urix#deprecated Needs some reworking read this. (https://github.com/lydell/urix) seems omitted # Dangling stuff, that seems unused. **mimelib**@0.2.14 is old, and dosen't seem to be used with the code base. Probably should just remove this... **har-validator**@5.1.5 is old and deperacated, but as far as I can tell is just dangling, can probably just remove without consiquance. **mkdirp**@0.5.1 is old and it's advised to update to mkdirp 1.x. but may take some reworking, because it's not using promises.. I cannot find any instances of this in the code base, so it may be safe to omit.
Nuggy self-assigned this 7 months ago
Nuggy removed their assignment 7 months ago
Sign in to join this conversation.
No Label
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.